Which devices are compatible with the MIO LINK?

ANT+ DEVICES

APPLE DEVICES

  • iPhone: 4S and higher
  • iPad: 3rd Generation, 4th Generation, Air
  • iPad Mini: 1st Generation, 2nd Generation
  • iPod Touch: 5th Generation

ANDROID DEVICES

Mio Global does not guarantee compatibility with all of the following devices. Be sure to check with your device manufacturer or carrier to confirm that your device meets the system requirements explained under the Android System Requirements section.

Compatible Android Devices (with Bluetooth 4.0):

  • HTC One (OS v4.3+), One M8
  • LG G2, G Pro2, G Flex, Vu3.0
  • Motorola Moto G, Moto X
  • Motorola Droid RAZR M, RAZR HD, RAZR Maxx HD
  • Motorola Droid Ultra, Maxx, Mini (OS v4.4+)
  • LGE Nexus 4, 5, 7
  • Samsung Galaxy S3, S4, S4 Active
  • Samsung Galaxy Note 2, Note 3, Note 10.1
  • Sony Xperia Z, Z1, Z1 Compact
  • Sony Xperia Tablet Z, Ultra, ZR, ZL
  • Sony Xperia SP, T, TX, V

Don’t see your device? Contact us

Android System Requirements:

  1. Your device has Android version 4.3 or higher. How do I check?
  2. Your device has Bluetooth 4.0
  3. Your app supports both of the above

If you’re unsure about whether your Android device meets the above requirements, check with your device manufacturer and carrier.

HOW TO CHECK YOUR ANDROID VERSION NUMBER

Please follow the steps below to see which version of Android your phone is running.
Note: the images below reflect the Nexus 5. Your device may differ.

Nexus 5 Settings

Step 1

Go into your list of apps and tap the “Settings” icon.

Nexus 5 Settings

Step 2

In Settings, scroll to the bottom and tap “About phone”.

Nexus 5 Settings

Step 3

Verify that your Android version is 4.3 or higher.

Still having trouble? Contact our Support Team to get personalized assistance. Email support@mioglobal.com.